Error subscribing to Google Calendar despite the correct credentials on Team Calendars for Confluence

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Failed when subscribing to Google Calendar, despite the credentials was inserted correctly, and the following error prompted on the screen.

(Auto-migrated image: description temporarily unavailable)
1 Specified calendar does not exist. Possible problems: Check that the Calendar URL you provided exists and you have the correct permissions to access it.

Cause

It is caused by wrong url was specified on the url, make sure that the url specified is on the ical format. Also make sure that, the url that you paste is public url instead of private. Please bear in mind that Team Calendars for Confluence doesn't support public address Google Calendar subscription.

Resolution

Paste the correct private url to the Team Calendars for Confluence, and make sure the credential is correct. You can get the correct private ical url by the following:

  • Click the small downward arrow beside the calendar name on Google Calendar

  • Go to Calendar Settings

  • Click the ICAL button on Private Address field and copy the url

  • Paste the link to the Team Calendars for Confluence with the correct credential

Updated on April 8, 2025

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