Error Submitting a Support Request via the Support Tools Plugin
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
The UI shows an error that begins with "An error occurred while creating your support request email:"
The following appears in the
atlassian-confluence.log
:
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2012-07-16 19:04:11,199 ERROR [http-8080-8] [support.tools.action.SupportToolsAction] execute
Error creating or sending your support request:
-- url: /plugins/servlet/stp/view/create-support-request/execute | userName: admin | referer:
http://localhost:8090/plugins/servlet/stp/view/
java.lang.ClassCastException: java.util.ArrayList cannot be cast to
com.atlassian.support.tools.properties.PropertyStore
at com.atlassian.support.tools.salext.AbstractSupportApplicationInfo.loadStore(AbstractSupportApplicationInfo.java:427)
at com.atlassian.support.tools.salext.AbstractSupportApplicationInfo.saveProperties(AbstractSupportApplicationInfo.java:397)
at com.atlassian.support.tools.salext.mail.AbstractMailUtility.sendSupportRequestMail(AbstractMailUtility.java:30)
Cause
This is caused by a known bug in the Support Tools Plugin and is being tracked in STP-158.
Resolution
The bug is fixed in version 3.0.8 of the STP plugin, so visit the Confluence Admin >> Manage Plugins page and update the Support Tools Plugin, which is located under the System Plugins section.
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