Empty Space Directory page after upgrading Confluence

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After upgrading to Confluence version 3.5.x, Space Directory page is empty.

Cause

This is most likely caused by customised Global Layout when Confluence was still in version prior to 3.5. Run the following query to confirm this:

1 SELECT * FROM DECORATOR WHERE DECORATORNAME = "decorators/global.vmd";

If this returns anything, it means that there has been some customisation made to your Global Layout, which is potentially causing the Space Directory to be unpopulated.

Resolution

Reset or fix the custom Global Layout. Please see the Modifying the global template or layout section of Customising the Confluence Dashboard for details on how to do this.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.