Email Notifications no Longer Work After Adding Mime.Types
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When clicking on the Share button or when mentioning a user in a comment or article nothing happens. The user also doesn't receive notifications.
Environment
Confluence Server and Data Center
Diagnosis
The following error appears in the atlassian-confluence.log:
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2016-03-21 16:23:38,596 ERROR [NotificationSender:thread-3] [plugin.notifications.dispatcher.NotificationErrorRegistryImpl] addError Error sending notification to server '<Unknown>'(-1) for INDIVIDUAL task (resent 1 times): Unknown error 'Could not initialize class com.atlassian.confluence.mail.template.MultipartBuilder' sending a notification.
NoClassDefFoundError: Could not initialize class com.atlassian.confluence.mail.template.MultipartBuilder
Cause
It can happen when you add a mime.type to the atlassian/confluence/confluence/WEB-INF/classes/mime.types file of the Confluence instance.
Solution
Solution (workaround)
Shutdown Confluence
Remove the line that you added to the mime.types file.
Start Confluence
ℹ️ If you need to access the original mime.types file, you can download the .tar.gz or .zip files of your Confluence version (see https://www.atlassian.com/software/confluence/download-archives) and locate the file on the path indicated above.
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