Drop-down Menus Stuck Open after Upgrading Confluence
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
After a Confluence upgrade, drop-down menus no longer collapse, despite moving the mouse away or clicking elsewhere. For example:

Causes
This is usually caused by upgrading the JDK (usually from 1.6 to 1.7), as old information can still be cached.
It can also be caused by a custom layout that is no longer compatible post-upgrade.
Resolution
Flush your plugin cache to clear any cached information from the previous JDK version.
Check your customisations via Confluence Admin > Layouts
Start with the Global Layout and Page Layout.
If any are customised, copy the contents of them to a text file to save for later use
Reset them to Default
Regardless of whether this works or not, now is a good time to review your customised layouts, so compare your customised layout to the current default one, and re-enter any customisations that you require (that do not cause the problem to recur).
A note on layouts - if they are customised, they will not be changed on upgrade, so as not to destroy your customisations. This can occasionally mean that layouts break post-upgrade, so rather than simply copy/pasting them back in after these steps, it's better to extract your customisations from the old layout and re-apply them to the new default layout.
Was this helpful?