Daily backup is broken after server migration

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

The legacy backup and restore system is available only in versions lower than Confluence 9.0. This means that scheduled backups, which used the legacy system, are no longer available.

  1. Confluence was migrated from a different server that enforces strict file permission

  2. Daily backup failed with the following error in the atlassian-confluence.log:

    1 2 3 4 5 6 7 8 9 10 11 2011-02-16 13:08:33,092 ERROR [http-8090-1] [atlassian.confluence.servlet.ConfluenceServletDispatcher]  sendError Could not execute action -- referer: http://<confluenceURL>/confluence/admin/backup.action | url:  /confluence/admin/dobackup.action | userName: admin java.io.IOException: Permission denied at java.io.UnixFileSystem.createFileExclusively(Native Method) at java.io.File.createNewFile(File.java:883) at com.atlassian.core.util.FileUtils.copyFile(FileUtils.java:465) at com.atlassian.core.util.FileUtils.copyFile(FileUtils.java:401) at com.atlassian.confluence.importexport.actions.BackupAction.execute(BackupAction.java:79) :
  3. In confluence.cfg.xml, custom folder location for daily backup is disabled:

    1 <property name="admin.ui.allow.daily.backup.custom.location">false</property>
  4. Manual backup works fine

  5. <Confluence Home folder>/backups belongs to the correct Confluence user and contains the correct file permission:

    1 drwxr-xr-x 2 confluence staff 68 18 Feb 08:20 backups

Diagnosis

  • Check for Confluence backup path in http://<confluence url>/admin/dailybackupadmin.action and you will notice it is set to a different folder - this, despite that custom directory location is disabled.

  • Check what is the <backupPath> value stored in the database.

1 select BANDANAVALUE from BANDANA where BANDANAKEY = 'atlassian.confluence.settings';

Resolution

  1. Set the setting to true again in confluence.cfg.xml:

    1 <property name="admin.ui.allow.daily.backup.custom.location">true</property>
  2. Restart Confluence

  3. Go to http://<confluence url>/admin/dailybackupadmin.action and edit the setting. Change the location to what it should be.

See also CONFSERVER-21844 - admin.ui.allow.daily.backup.custom.location still allows Confluence to create backup to custom location even if it's set to false

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.