Creating Jira Issues from highlighting text fails with NullPointerException

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

Creating a Jira issue by highlighting text fails with a NullPointerException:

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http://blogs.atlassian.com/2013/12/confluence-5-4-jira-integrates-confluence-like-never-before/

The following appears in the atlassian-confluence.log:

1 2 3 4 5 6 2014-09-19 11:33:28,412 ERROR [ajp-bio-127.0.0.1-8009-exec-1] [ContainerBase.[Standalone].[localhost].[/]] log Unhandled exception occurred whilst decorating page -- referer: https://test/pages/viewpage.action?pageId=2333333 | url: /plugins/servlet/applinks/proxy | userName: test java.lang.NullPointerException at com.atlassian.confluence.plugins.jira.AbstractProxyServlet.doProxy(AbstractProxyServlet.java:119) at com.atlassian.confluence.plugins.jira.AppLinksProxyRequestServlet.doProxy(AppLinksProxyRequestServlet.java:75) at com.atlassian.confluence.plugins.jira.AbstractProxyServlet.doGet(AbstractProxyServlet.java:46)

Diagnosis

Try to create a Jira issue by inserting it manually in page edit mode, the '+' >> Jira Issue. If that fails, then you might be hitting this bug: CONFSERVER-34922 - When browsing "plugins/servlet/applinks/proxy", a NullPointer Exception is given when no server id and path is given

If you are able to insert Jira issues while in page edit mode (the issue only affects creating Jira Issues by highlighting text), then please proceed to the Resolution below

Cause

Third party plugins, such as the PoolParty PowerTagging plugin.

Solution

Resolution

  • Navigate to Confluence Admin >> Manage Add-Ons, and enable Safe mode.

  • If enabling safe mode resolves the issue, please activate the disabled plugins one-by-one until the issue appears again. So far, we have identified the PoolParty PowerTagging plugin as one culprit causing this issue.

Updated on April 8, 2025

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