Converted page becomes blank when edited
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When publishing a page that has been converted to the new editor, it will be properly displayed. However, upon editing it, all of its existing page's content will be blank:

Cause
When a page has unsupported content, although the conversion works, Confluence will not be able to have it rendered.
Besides the blank content only while being edited, there is also a possibility of the "Unsupported content" message be displayed when publishing it.

In this case, the edit mode allows the content to be rendered. The cause for this symptom is associated with a Confluence bug:
Solution
Simply publishing the page will allow it to be rendered and remove the unsupported part. As a workaround, copying the page allows its body to be visible while editing it. This way, it can be copied into the original page with the blank content.
Note that it can affect templates. In this case, copying and pasting unsupported content into the template will trigger the behavior. The workaround will be to copy the content from a created page:
Copying the content
Tap the Create button to create a new page and select the template.
The edit mode of the page will be blank. Publish it to have it rendered.
Edit the page and copy its content.
Pasting the content
Edit the template
If it is a space template, as a space admin, go to Space settings > Content Tools > Templates
If it is a global template, as an administrator, go to the cog icon on the top right
> Global Templates and Blueprints
Tap edit and paste the copied content into the template.
Save the edit to the template.
Was this helpful?