Confluence will not start up due to no server id found

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Confluence will not start although Tomcat starts without issue. Nothing is reported to the atlassian-confluence.log.

When hitting the baseURL, confluence reports a Bootstrap exception: Unable to bootstrap application, Failed to parse config file: Error on line 1 of document : Content is not allowed in prolog.

No server id found.

(Auto-migrated image: description temporarily unavailable)

Cause

Confluence needs to be able to load the configuration from the confluence.home/confluence.cfg.xml file. There is a problem with that file.

This could also be caused by file system corruption.

Resolution

  • Validate the confluence.cfg.xml file for consistency in formatting of an xml file.

  • Review any configuration files that have been edited recently to ensure the syntax is correct and there are no elements left open.

    ℹ️ Restoring any recently edited files to default can be done by installing a new, default instance of confluence and copying them into place in the existing environment.

  • If neither of the above help, please check for file system corruption via chkdsk in Windows or fsck in Linux.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.