Confluence Usage statistics increased post Confluence 5.7 upgrade

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Post upgrading your Confluence instance to version higher than Confluence 5.7 from Confluence instance below version 5.7 resulted in increased number of Confluence Usage - Contents statistics under Confluence Administration >> System Information page.

Diagnosis

The number of Contents under the Confluence Usage on System Information page pre upgrade shows smaller amount of number compared to the statistics post the upgrade as per shown below.

  • Pre Confluence 5.7 Upgrade

    (Auto-migrated image: description temporarily unavailable)
  • Post Confluence 5.7 Upgrade

    (Auto-migrated image: description temporarily unavailable)

Cause

The difference in the number of the Contents under the Confluence Usage statistics on pre and post upgrade are actually caused by the changes of how Confluence treat attachments starting Confluence 5.7 (Please refer to Confluence 5.7 - Upgrade Notes).

From this version onwards, attachments are treated as ContentEntityObjects and therefore also stored on the CONTENT table in the database instead of just stored in its own table - ATTACHMENTS.

Therefore, the content count on the Contents under the Confluence Usage statistics, now considers an attachment as a content as well.

The below query might help you understand the quantity of attachment contents in your CONTENT table itself.

1 SELECT contenttype, COUNT(*) FROM CONTENT GROUP BY contenttype;
Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.