Confluence Unable to Start Due to Insufficient Access Privileges to Database
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Confluence is unable to start, possibly after a migration to a new server or database. The following error appears in web browser while accessing Confluence:
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HTTP Status 404 -
type Status report
message /
description The requested resource (/) is not available.
The following appears in the atlassian-confluence.log
:
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2010-04-27 21:18:53,441 ERROR [main] [sf.hibernate.util.JDBCExceptionReporter] logExceptions SELECT permission denied on object 'BANDANA', database 'Confluence', schema 'dbo'.
Cause
The database user used by Confluence to connect to the database has insufficient permission. In this case, the database user is lacking the SELECT
permission.
Resolution
Grant necessary database access privileges to the database user. A Confluence restart may be required.
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