Confluence starts up with error message Unable to load class for JSP
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Confluence starts up with error message displayed on login screen:
The following appears in the
atlassian-confluence.log
:
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Cause
org.apache.jasper.JasperException: org.apache.jasper.JasperException: Unable to load class for JSP
at org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:161)
caused by: org.apache.jasper.JasperException: Unable to load class for JSP
at org.apache.jasper.JspCompilationContext.load(JspCompilationContext.java:630)
caused by: java.lang.ClassNotFoundException: org.apache.jsp.errors_jsp
at java.net.URLClassLoader$1.run(Unknown Source)
Cause
Root cause is lack of space to load class files needed to start up Confluence.
Resolution
Disable automatic backups and move to a Production Backup Strategy.
Ensure Confluence has enough disk space and meets the minimum Server Hardware Requirements Guide for disk space.
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