Confluence is not accessible after installation on CentOS 7

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

After following the instructions for Installing Confluence on Linux when using CentOS 7, you may find that Confluence is not accessible, and there are no errors in the logs to suggest why Confluence is not accessible.

Diagnosis

  • Is the Confluence service listening on IPv4? Running netstat -a will determine what protocol Confluence is listening on, as well as what port it's listening on.

  • Is a system firewall, such as firewalld or iptables running?

    • If so, try stopping those firewalls temporarily to see if they're blocking connection to Confluence

  • Can external machines telnet to Confluence on the connection port (8090 by default)?

Cause #1

Confluence may not be listening on an IPv4 address, and instead will be listening on an IPv6 address.

Resolution #1

Cause #2

Connections to Confluence may be blocked by firewalld, which is included in CentOS 7 by default.

Resolution #2

  • Configure your firewall software to permit connections to Confluence on the port(s) defined in server.xml. Consult your firewall documentation for details.

Updated on April 8, 2025

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