Confluence is inaccessable after starting up Confluence 4.0.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

  • Confluence 4.0 has started

  • The Java process is running (via ps -ef or taskmgr.exe)

  • You have not modified the <confliuence-4.0-installation directory>/conf/server.xml

  • You are expecting confluence to be running on port 8080

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Cause

The default port of Confluence has now been changed from port 8080 to 8090.

Workaround

You can modify the <confliuence-4.0-installation directory>/conf/server.xml file to point this back to port 8080

1 2 3 4 5 6 <Server port="8000" shutdown="SHUTDOWN" debug="0"> <Service name="Tomcat-Standalone"> <Connector className="org.apache.coyote.tomcat4.CoyoteConnector" port="8090" <---change here ...... maxProcessors="75" enableLookups="false" redirectPort="8443" acceptCount="10" debug="0" connectionTimeout="20000" useURIValidationHack="false" URIEncoding="UTF-8"/>

If you were using port 8080 and wish to use the new port 8090 port, you will need to Configuring the Server Base URL and modify the base URL to reflect the new port 8090 URL.

Resolution

Please contact the plugin provider for a Confluence 4.0 compatible update.

Updated on April 8, 2025

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