Confluence Inline comments are being resolved automatically when using UI Steps macro
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Inline comments are being resolved automatically when the page is published without any changes or when users are added to page restriction.
Environment
Confluence Server or Data Center
RefinedToolkit for Confluence 2.2.5
Diagnosis
After publishing a page without making any changes to it or editing the page restrictions, inline comments are suddenly resolved. This can be confirmed by checking the "missing" comments in the Resolved Comments section.
To go to the Resolved Comments section on a page, click on the ellipsis (. . .) on the upper right corner
Click on Resolved Comments
Look for the missing comments from the page.
The problem is not recorded in the application logs so it's only visible in the UI.
⚠️ The error is only present in pages with the UI Steps macro, however, the comments that are getting resolved automatically may be or not inside the UI Steps macro.
Cause
There's a problem with the macro that has not been identified by Atlassian but is resolving the inline comments.
Solution
Update the RefinedToolkit for Confluence by following this guide.
If the problem remains, contact vendor support here.
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