Confluence Fails to Start Due to a NoSuchFieldError (LUCENE_31)

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Confluence does not start.

The following appears in the atlassian-confluence.log:

1 2 ERROR [main] [confluence.search.lucene.ConfluenceSearcherInitialisation] initialise Error encountered while warming up searcher: LUCENE_31 java.lang.NoSuchFieldError: LUCENE_31

Cause

This error usually happens due a corrupted installation directory.

Resolution

  1. Shutdown Confluence

  2. Create a backup of the entire Confluence installation directory

  3. Download a new standalone zip file (same version of your current Confluence)

  4. Extract it

  5. Replace the current installation directory with the newly extracted files. However please keep the following files from your current installation directory and replace the ones in the new installation directory with them:

    server.xml located in <CONF_Install_Dir>/conf/

    confluence-init.properties located in <CONF_Install_Dir>/confluence/WEB-INF/classes/

  6. Restart Confluence

If you face any problems regarding plugins, please clear your plugin cache.

Updated on April 8, 2025

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