Confluence DC: Resolve Task Report Macro showing tasks from previous versions

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Task Report Macro is showing tasks from previous versions of the page.

Environment

Confluence 7.4.3

Diagnosis

Cause

In rare situations, the "AO_BAF3AA_AOINLINE_TASK" DB table can get corrupt or out of sync with current tasks.

Third-party apps can cause this; applying the resolution steps from this KB will not resolve the cause of corruption, but will clear the corruption itself.

Solution

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

  1. Perform a full backup of the Confluence Database.

  2. Shutdown Confluence.

  3. Execute the following SQL Query:

    delete from "AO_BAF3AA_AOINLINE_TASK";
  4. Start Confluence.

Confluence will re-populate "AO_BAF3AA_AOINLINE_TASK" DB table based on current tasks, skipping tasks in previous page versions

Updated on June 16, 2025

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