Component and Version fields not showing when adding a JIRA Issue to a Confluence page
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When using the Create JIRA Issue function from Confluence, the Version and Component fields do not show.
Cause
There are no Versions or Components in the JIRA project that the issue is being created in.
Resolution
Add Versions and/or Components to the project and the fields will show in Confluence. See Managing Versions and Defining a Component for instructions.
Was this helpful?