Character Encoding Issues when using JASIG CAS Authenticator

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

You are using the JASIG CAS Connector and are having Encoding Issues with multibyte characters.

Diagnosis

Follow the directions on this page: Troubleshooting Character Encodings

This document applies may to you if the output in Test 2 is not the same as Test 1.

Cause

The CAS connector has an encoding problem that is documented here: https://issues.jasig.org/browse/CASC-122 (Offsite Link)

Solution

Resolution

JASIG has a workaround posted in the troubleshooting section on this page: https://wiki.jasig.org/display/CASC/Configuring+Confluence+with+JASIG+CAS+Client+for+Java+3.1

Updated on April 2, 2025

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