Changing content directly via SQL does not show immediately

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When using SQL to change content in the database, the change does not show immediately in the UI. This could apply to permissions, group names, page content, and most content.

Cause

The cache is inconsistent with the database.

Resolution

Flush the caches at Administration >> Cache Statistics, wait for them to time out, or restart Confluence.

Updated on April 8, 2025

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