Can't Find Users Through Decisions Blueprint
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Using the create wizard to start a new decision it's unable to find any users while searching in either the Owner or Stakeholders field.
Cause
Confluence's index wasn't properly updated or could be culprit.
Resolution
Schedule a downtime to perform it, because after the restart your users will not have the search available due the rebuild of the indexes.
Shut down your Confluence server.
⚠️ Make a backup of your
<confluence-home>/index/plugin
directory if it exists. This is where the Usage Tracking plugin stores it's index for the usage statistics and it cannot be rebuilt.⚠️ If you're in Confluence 4.2 onwards, make a backup of your
<confluence-home>/index/edge
directory if it exists. This is where the index of Likes and Popular Content are stored and cannot be rebuilt.Remove the
<confluence-home>/index
directory.If in step 2, you have the
<confluence-home>/index/plugin
directory, create the<confluence-home>/index
directory and copy in the backup of<confluence-home>/index/plugin
directory made in step 2.If in step 3, you have the
<confluence-home>/index/edge
directory, create the<confluence-home>/index
directory and copy in the backup of<confluence-home>/index/edge
directory made in step 3.Restart server.
ℹ️ A new index directory will be created upon restart of your application if it does not exist.
Now perform the manual re-indexing of your site to build a brand new index from scratch.
If you still cannot find your content, please contact Confluence Support.
Was this helpful?