Cannot Restore from XML Backup when Confluence is Backed by MySQL
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When restoring a Confluence site or space XML backup, the progress bar eventually stops advancing and stays that way indefinitely.
No errors appear on screen or in the logs. The atlassian-confluence.log
indicates that the import has been started, but nothing follows:
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2012-06-10 16:38:10,273 INFO [Long running task: Importing data] [confluence.importexport.actions.ImportLongRunningTask] runInternal Beginning import by user admin
Cause
MySQL's packet size setting may be set too low.
Resolution
Set the MySQL packet size to 32M or larger and restart MySQL Server.
For MySQL versions 4.0 and later, use this syntax:
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shell> mysqld --max_allowed_packet=32M
Alternatively, you can do this on your MySQL server's settings by editing MySQL's my.cnf
file (often named my.ini
on Windows operating systems). Locate the [mysqld]
section in the file, and add/modify the following parameters:
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[mysqld]
...
max_allowed_packet = 32M
...
For more information, please refer to MySQL manual: http://dev.mysql.com/doc/refman/5.0/en/packet-too-large.html.
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