Cannot Re-Add LDAP User

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When someone try to enable an account that was disabled before in Confluence, the same user account will get login failed.

Cause

There may be two different causes for this behavior:

  1. The user was probably in the database cache since this same user account was previously active in Confluence database.

  2. LDAP could be using the disabled user account and not the correct enabled one.

Resolution

  1. Drop the LDAP Directory in Confluence (Browse > Confluence Admin > User Directory).

  2. Create the same LDAP Directory.

  3. Force synchronization manually.

⚠️ Ensure to copy the same information from the original LDAP Directory.

Updated on April 8, 2025

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