Cannot Login After Upgrade Due to Using JIRA for User Management

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Users can't log in to the instance after upgrading.

Cause

Step 6 of Delegate user management to use JIRA logins was skipped. The upgrade guide describes moving <confluence-home>/confluence/WEB-INF/classes/atlassian-user.xml from the old instance into the new.

Resolution

Modify atlassian-user.xml to point to the osuser repository:

1 2 3 4 ... <osuser key="osuserRepository" name="OSUser Repository"/> ...
Updated on April 8, 2025

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