Cannot apply Team Calendars for Confluence license due to 'Invalid license specified' error
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When trying to add a Team Calendars for Confluence License to Confluence, an error pops up on screen: "Invalid license specified"
Cause
There are more than one possibilities for this error. The most common ones are listed below:
The license is being inserted into the License Details for Confluence rather than Team Calendars for Confluence
The base URL incorrectly set
Resolution
Please ensure that you are placing the license at Confluence Admin > Team Calendars for Confluence > License Configuration
Please check that the base URL set at Confluence Admin > General Configurations matches that of the actual URL used to access Confluence. Please ensure that the protocol is also set correctly (e.g. http vs https).
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