Cannot Add an Event in People Calendars

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

  1. In People Calendars, no response was visible when adding an event for a user name

  2. Despite that they are all valid users, they do not exist in the People directory thus they cannot be added in People Calendars

Cause

Just like the People Directory, the Team Calendars for Confluence relies on Confluence indexes. If the index are not up to date (eg. due to a data restore that did not trigger Confluence re-index) then the Team Calendars for Confluence will not be able to locate some users and treat them as non existent users.

Resolution

How to Rebuild the Content Indexes From Scratch on Unclustered Confluence.

Updated on April 8, 2025

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