'Bad Request' displayed and Time Zone requested when viewing embedded Team Calendars for Confluence

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Confluence will display a warning box saying 'Error(s) Occurred - Bad Request' and will continuously prompt for a Time Zone when viewing a page with an embedded Team Calendars for Confluence macro.

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Diagnosis

This is either caused by a problem with your base URL or network interference.

Resolution

  1. Check that the base URL is configured properly

  2. Ensure your proxy is properly configured: Running Confluence behind Apache

  3. Try disabling any firewalls or network security to see if this is interfering. Note that Atlassian doesn't offer support for this.

Updated on April 8, 2025

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