Atlassian Support Tools content not loading due to Javascript error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

When an administrator navigates to Confluence Admin > Atlassian Support Tools, the sidebar tabs of the support tool function load properly, but the main content just keeps loading as seen on the screenshot below:

(Auto-migrated image: description temporarily unavailable)

Diagnosis

No errors can be found in the logs, browser may display various Javascript-related errors.

Cause

The cause is having the JavaScript served in header option disabled under Confluence Admin > General Configuration.

Solution

Resolution

The solution is to enable the JavaScript served in header option disabled under Confluence Admin > General Configuration.

Updated on April 8, 2025

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