Atlassian Marketplace server not reachable due to "javax.net.ssl.SSLException: Received fatal alert: protocol_version"
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Confluence is unable to reach the Atlassian Marketplace over HTTPS.
Diagnosis
After Confluence tries to reach the Marketplace, an error like the following appears in the application logs:
1
2
2021-01-11 17:17:12,457 WARN [https-jsse-nio-443-exec-64] [atlassian.upm.pac.PacClientImpl] fetchMpacAppInfo Error when querying application info from MPAC: com.atlassian.marketplace.client.MpacException: javax.net.ssl.SSLException: Received fatal alert: protocol_version
-- referer: https://my.confluence.com/plugins/servlet/upm/marketplace/featured?source=side_nav_find_new_addons | url: /plugins/servlet/upm | traceId: 31a652053a96ebbe | userName: BBunny
Cause
Check the Java options used to start up Confluence for an incorrect TLS client protocol. For example:
1
-Djdk.tls.client.protocols=TLSv1
Solution
Remove the offending TLS client protocol entry using Configuring System Properties as a guide and restart Confluence.
Was this helpful?