Apps fail to start up after upgrading to Confluence 7.10 or later

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

After upgrading to Confluence 7.10, you see a message that a number of your apps failed to start up.

Cause

In Confluence 7.10 we upgraded the version of Xstream bundled with Confluence. This was a major upgrade that impacted some apps.

See XStream 1.4 upgrade for full details of the change.

Workaround

We recommend upgrading Confluence in a test environment first, and checking that all your apps start up and work as expected. If you encounter a problem, you may be able to upgrade that app prior to upgrading Confluence, if the vendor has made a compatible version available.

If you do find an app doesn't start up, you'll need to:

  • upgrade the app, if a new version is available on Marketplace, or

  • contact the app vendor for assistance.

Updated on April 8, 2025

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