After Upgrade to Confluence 3.5 with Crowd, Other Users Cannot Log in
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Users outside of Crowd Directory cannot log in when Confluence is integrated to Crowd version 2.1 - 2.2.1.
Cause
This is caused by a known bug, CONF-22080, which causes the crowd user authentication to fail to fall check any directory after Crowd in Confluence's User Directories table.
Workaround
This workaround is only required if you are using Crowd 2.1 - 2.2.1, and cannot upgrade Crowd.
Upgrade to 3.5 using an atlassian-user.xml configuration that does not mention Crowd.
Log in to Confluence as user who is a member of confluence-administrators, and browse to Confluence Admin > Security > User Directories, manually add the crowd directory and ensure it is the last directory in the user directory table.
Limitations
With this workaround in place, users in Crowd and any other user directory will be authenticated in that earlier directory, and not in Crowd. If those user accounts are configured with different passwords, this would mean that users will have to use different passwords to login to Confluence.
Resolution
Upgrade to Crowd 2.2.2 or higher.
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