After Logging in to Confluence as admin, Notifications Appear that 'health check has failed in your system'

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After logging in to Confluence, notifications appear that 'health check has failed in your system'.

Cause

If server is undergoing maintenance such as VM backup or virus scans, then this can cause the health check to timeout before completion.

Workaround

Increase the Health-check timeout to 60000ms:

Add Java parameter to JVM settings, (see Configuring System Properties for more details)

1 -Datlassian.healthcheck.timeout-ms=60000
Updated on April 8, 2025

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