After a successful migration URL links are broken in the new cloud instance

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

After migrating Jira or Confluence from Data Center to Cloud or between Cloud sites, some URLs in the recently migrated instances might appear broken as they still point to the old URLs. This includes any links between individual entities in the migrated instances, for example:

  • Remote links between Jira work items or Confluence pages

  • Links to attachments

  • Links pasted by users as URLs into comments or pages

Diagnosis

Check any links like

  • Remote links between Jira work items or Confluence pages

  • Links to attachments

  • Links pasted by users as URLs into comments or pages

Cause

After migrating, your instances start living under different URLs. Any links from other instances (Jira or Confluence) would still reference the old URLs, which either no longer work or represent the pre-migration instances. Such links aren’t automatically updated after migration, especially if they were pasted by users into comments or descriptions as URLs.

To fix such links, you need to complete a post-migration task that updates all broken links to their new destinations.

Solution

You can use Link fixing to update all broken links in bulk.

Link fixing page displaying a list of connected product sites

You can use link fixing to update links in Jira and Confluence, including the following migration types:

  • From Data Center to Cloud

  • From Cloud to Cloud

To learn more about link fixing, supported link types, and detailed steps on how to update links after migration, see the following page.

Learn more about fixing links after migration

Reaching out to support in case of problems

You should reach out to Atlassian Support only if you encounter problems with the solution described above. In this case, Atlassian Support can use this or a similar legacy way to fix the links for you.

Contact Atlassian Support

To reach out to Atlassian Support, raise a request, and select Migration support.

Provide the data

To update the links in your instances, we’ll need information about the destinations of links:

  • Current URL in cloud: URL of the cloud instance that will be the new destination for links.

  • Original URL in server: Original URL of the instance it was migrated from. If possible, also provide Server ID.

  • (Optional) Production instance URL: If this instance was migrated from a staging instance, also provide the URL of the corresponding production instance. If possible, also provide Server ID.

Additional data and app links

If you’d like to fix links between instance in different cloud sites, we’ll also need the URLs of both sites. In this case, you also need to create application links between your products before reaching out to us (for products that live in a single site, app links are created automatically). Learn how to create app links

Legacy way of fixing links

We also have a legacy way of requesting link fixes. If the steps described here don’t work for you, you can try it instead. In some cases, you might also be asked by our Support team to complete it. For more information, see: Legacy way of fixing links.

Updated on May 16, 2025

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