Add Space Redirects to an Incorrect URL (Confluence 4.2.3 and above)

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

After changing the Confluence URL, or the Confluence context path, you are unable to add a space (it keeps redirecting to the old URL).

This affects only Add Space with this popup (Confluence 4.2.3 and above):

(Auto-migrated image: description temporarily unavailable)

After clicking add, you will be redirected to the old URL, which does not exist, hence the space is not created.

Diagnosis

First of all, check if the Server Base URL set in Confluence Admin >> General Configuration is correct (set to the URL you use to access Confluence). If it is correct, then proceed to the Resolution below.

Cause

The plugin responsible for that Add Space popup is caching the old Server Base URL.

Solution

Resolution

  1. Shutdown Confluence

  2. Remove the following folders from your Confluence Home Directory

    1. bundled-plugins

    2. plugins-osgi-cache

    3. plugins-cache

    4. plugins-temp

  3. Startup Confluence again (the plugin cache will be rebuilt upon startup)

Updated on April 7, 2025

Still need help?

The Atlassian Community is here for you.