White/blank screen after upgrade

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

White or blank screen and no error in the logs after upgrade.

Cause

  1. Bitbucket Server Installation files might be corrupted.

  2. Bitbucket Server has a misconfigured server.xml.

Resolution

  1. Download the latest Bitbucket Server installation file and unpack it to another directory.

  2. Make sure you have the server.xml configured properly according to Change the port Bitbucket listens on. For Stash 3.8 (and future versions) the server.xml file is located in the <bitbucket server home directory>/shared directory. You need to manually update your custom configurations in shared/server.xml for the upgrade to Stash 3.8 or later, as described in here.

Updated on April 8, 2025

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