User cannot create issues in Jira from Bitbucket Server/Datacenter after upgrade to Jira 9.x

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The content on this page relates to platforms which are supported; however, the content is out of scope of our Atlassian Support Offerings. Consequently, Atlassian cannot guarantee support. Please be aware that this material is provided for your information only and you may use it at your own risk.

After an upgrade to Jira 9.x, while trying to create an issue from Bitbucket, the create fails with "An unexpected response was received from Jira":

(Auto-migrated image: description temporarily unavailable)

Environment

  • Bitbucket Server and Data Center 7.15 or older

  • Jira 9.x or newer

Diagnosis

While trying to create an issue from Bitbucket in Jira, it fails with the message: "An unexpected response was received from Jira."

After checking the HAR file, it is possible to see a call to this endpoint:

1 <bitbucket_base_url>/rest/jira-integration/1.0/servers/XXXXXXXXXXXXXX/projects

The answer to the call is HTTP 200, which does not indicate an issue, but the answer to the call has this message: JiraErrors{errorMessages=[Issue Does Not Exist], errors={}}.

Cause

One of the calls made from Bitbucket in the backend is to this endpoint:

1 bitbucket/rest/api/2/issue/createmeta/\{projectIdOrKey}/issuetypes

But the createmeta endpoint was deprecated in Jira 9.x: Createmeta REST endpoint to be removed.

Solution

Upgrade Bitbucket to 7.16 or newer version.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.