Updating add-ons by file upload hangs using UPM

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

Uploading a JAR just using UPM as described in Updating add-ons by file upload just hangs on the spinner. See image below for example:

(Auto-migrated image: description temporarily unavailable)

No specific error was shown in the logs atlassian-bitbucket.log.

Diagnosis

After inspecting the Javascript on the browser (An example on how to do that for Chrome can be found here), the root cause could be determined.

Cause

The proxy was responding with 413 (Request Entity Too Large).

Solution

Resolution

For the reported issue and proper illustration, the proxy was a nginx. The client_max_body_size parameter was set to 8m whilst the plugin JAR was 22mb large. After setting the ngnix client_max_body_size parameter to 50m the plugin installation was successfully completed.

Updated on April 16, 2025

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