Unable to update UPM
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
A message such as the following is displayed when trying to install a plugin using the Universal Plugin Manager:
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The system attempted to connect to http://<SOME_IP_ADDRESS>:7990/rest/plugins/1.0/pending/31780996-ff30-4041-8405-642cf500210b to
retrieve the status of your operation, but failed. This may indicate a
problem with the base URL configuration of your instance. Try refreshing
the page to see if the operation completed, and see the UPM documentation for more details about this error.
Cause
An incorrect
Base URL
is configured and does not match the proxyName parameter in theserver.xml
file if you have a proxy.Configure the proxy parameters properly (
redirectPort
,scheme
,proxyName
) depending on your scenario and review the reverse proxy settings.
If you are running Bitbucket Server 5.0+
As of Bitbucket Server 5.0, the connector properties have changed and are now configured in bitbucket.properties
.
The proxy properties are now proxy-name
, proxy-port
, etc. More information is available in Proxy and secure Bitbucket.
Resolution
Please refer to Specify the Bitbucket base URL.
Depending on your scenario you have to use the documents below:
You can always update the plugin manually. Refer to Updating the Universal Plugin Manager.
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