Unable to access server on fresh install on Linux
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
As of Bitbucket Server 5.x+, no logs are written to the BITBUCKET_INSTALL directory. The contents of catalina.out will be written to BITBUCKET_HOME/log/atlassian-bitbucket.log file.
Symptoms
After installing and starting Bitbucket Server for the first time, you're unable to access the server on http://<SERVER_NAME>:7990/
The catalina.out
indicates that server started without error:
1
2
3
4
5
INFO: Starting Servlet Engine: Apache Tomcat/7.0.54
Aug 06, 2014 8:58:05 PM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-7990"]
Aug 06, 2014 8:58:05 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 13332 ms
Diagnosis
Check that port 7990 is allowing incoming connections:
1
sudo iptables -L
Cause
You're unable to access the server because the firewall is preventing connections on port 7990.
Solution
Resolution
Allow incoming connections on port 7990 by running the following command:
1
sudo iptables -I INPUT -p tcp --dport 7990 -j ACCEPT
Was this helpful?