The database, as currently configured, is not accessible

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

On first accessing Bitbucket Server after installation on Windows (using the internal database for 1.2 and higher), an error like the following is shown:

(Auto-migrated image: description temporarily unavailable)

Possible cause

There may be multiple possible causes for this issue. This article deals with the following:

  • The user running Bitbucket Server does not have the "Modify" permission on the BITBUCKET_HOME.

Resolution

Do the following:

  • If you are not sure where your BITBUCKET_HOME folder is,

    • open the folder where you installed Bitbucket Server,

    • open setenv.bat, and look for the line: set BITBUCKET_HOME=...

  • Then,

    • Stop Bitbucket Server,

    • Navigate to your BITBUCKET_HOME with Windows Explorer,

    • Right click on the folder, and click on the Properties,

    • in the Properties window, click on the tab Security,

    • Underneath the Group or user names list, click on the Edit button,

    • Click on the user account used to run Bitbucket Server, and in the Permissions for ... list, make sure all the checkboxes Modify, Read & execute, List folder contents, Read, Write are checked in the Allow column,

    • Click on OK to close the Permissions windows, and then on OK on the Properties windows, to make the permissions effective

    • Restart Bitbucket Server

Updated on April 8, 2025

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