Resolve "Page Not Found" Error in Bitbucket Data Center Commits
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Resolve the 'Page not found' error in Bitbucket Data Center.
Diagnosis
When viewing a commit in Bitbucket Data Center’s web UI, an error message appears saying “Page not found.” Upon clicking the “Return to Dashboard” button, the commit can be viewed normally.
Cause
This problem can occur if the Bitbucket Server - Tag app, which comes pre-installed with Bitbucket Data Center, is disabled.
The app is integral to Bitbucket Server and required for its proper functioning, and should not be disabled.
Solution
To resolve this problem, follow these steps:
Navigate to
<BaseURL>/plugins/servlet/upm/manage/system
(where<BaseUrl>
is the URL of your Bitbucket Data Center).Scroll down to and click on Bitbucket Server - Tag.
Click Enable.
Was this helpful?