Cannot get past license screen during installation

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

While upgrading or installing Bitbucket Server, users cannot get past the "enter license" screen although they have a valid license.

Cause

This issue is likely caused by multiple Atlassian applications (or other Java web applications) being located at the same hostname and context path and overwriting each others JSESSIONID (changed to BitbucketServerid in BitbucketServer 5.x onwards) cookies.

For example, if you have JIRA located at:

https://my-domain:8080

and Bitbucket Server located at:

https://my-domain:7990

Then accessing a page from JIRA will invalidate your Bitbucket Server session.

Resolution

To confirm whether this is the case, try clearing the cookies from your browser and using Bitbucket Server. You should experience no problems until you log into JIRA again.

To fix the root cause, please follow Moving Bitbucket Server to a different context path

Updated on April 8, 2025

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