Bitbucket Server Fails to Start - SEVERE: Error listenerStart

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

Bitbucket Server fails to start.

The following appears in the catalina.out:

1 SEVERE: Error listenerStart

As of BitbucketServer 5.x+, no logs are written to the BITBUCKET_INSTALL directory. The contents of catalina.out will be written to BITBUCKET_HOME/log/atlassian-bitbucket.log file.

Diagnosis

A long path to a file name should appear complete, e.g.:

1 <Bitbucket Server home directory>/atlassian-bitbucket/WEB-INF/classes/com.atlassian.bitbucket/internal/johnson/HomeApplicationEventCheck.class

Cause

The application files were corrupted by the utility used to unpack the download.

Solution

Resolution

Unpack the download with another utility e.g. 7-zip

Updated on April 2, 2025

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