"An error was encountered while retrieving plugin details" when trying to add a plugin

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When trying to add a plugin, you get the error, "An error was encountered while retrieving plugin details"

Cause

There may be a firewall or proxy proxy blocking the following URLs:

  • https://marketplace.atlassian.com

  • https://plugins.atlassian.com

Workaround

You can upload the Plugin manually:

  1. Download the plugin

  2. Go to Administration Page - Plugins & Apps - Plugins

  3. Go to Install tab - Upload Plugin (on the right)

  4. Chose the plugin and click on upload}

Resolution

Ask your Network Administrator to allow access to the above URLs.

Updated on May 22, 2025

Still need help?

The Atlassian Community is here for you.