"xz: (stdin): File format not recognized" error in Pipelines

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

The purpose of this KB article is to provide the reason why this error message generally occurs and how to resolve it.

Diagnosis

You are attempting to obtain a compressed file from an external location using a method such as cURL or wget and uncompress it. When you execute the build, however, the build fails with a variant of the following error message:

1 2 3 xz: (stdin): File format not recognized tar: Child returned status 1 tar: Error is not recoverable: exiting now

Cause

The most common cause is as follows:

  • The file location that you are calling is either unavailable due to server downtime/authentication failure, or the file location has simply moved and the link is no longer valid

Solution

To further test and diagnose the issue so that it may be resolved:

  1. Attempt to browse to the URL file location in a web browser, or attempt to perform a cURL/wget command against the URL locally and observe the result

  2. If there is a failure, analyse the error that is displayed and attempt to locate the correct URL so that this may also be tested locally

  3. Once the correct URL has been found and tested, update any references to it in your Pipelines YML configuration (or in any variables if these are used)

If the above instructions do not assist in resolving the issue, please raise a support ticket or raise a community support ticket for further assistance with this.

Updated on April 11, 2025

Still need help?

The Atlassian Community is here for you.