User cannot accept invitation to Bitbucket Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.
Summary
You may encounter an issue where you or a user that you have invited to join a Bitbucket Cloud workspace is unable to accept the invitation when clicking on the Accept Invitation button found in the email.
Environment
Bitbucket Cloud
Diagnosis
Upon clicking the button to accept the invitation, the user is redirected to log in to their Atlassian account. However, after logging in, the user is redirected to this URL: https://start.atlassian.com/ instead of the correct URL necessary to accept the invitation.
Cause
If you or your organization has implemented email cybersecurity measures, this can impact legitimate URL redirections if our Atlassian email addresses are not added to your security whitelist. Additionally, unresolved pending invitations for the same user within multiple groups in the workspace can cause conflicts that prevent new invitations from being sent or appearing correctly.
You can determine if this is the problem or not by checking the user's invitation history across all groups in your workspace. Look for pending invitations. If conflicting invitations are present, they must be canceled before sending a new one.
You may also notice incidents related to legitimate URL redirections by hovering your mouse over the button to accept the invite. For example: "
https://testdefender.example.com/safe-redirect/https://id.atlassian.com"Additionally, users should avoid accidentally unsubscribing from invitation emails. When receiving an invitation email, ensure you click 'Accept' to join the workspace instead of 'Unsubscribe,' as this can prevent you from receiving future invitations.
Solution
To resolve this, your email administrator will need to whitelist our Atlassian email addresses as follows to ensure that our emails are not blocked from being received or otherwise impacted by an issue such as this:
noreply@am.atlassian.com
noreply+XXXXXXX@id.atlassian.net
no-reply@atlassian.com
noreply@mailer.atlassian.com
notifications-noreply@bitbucket.orgAdditionally, if the issue persists or no email is received, it's crucial to verify the invited user's email preferences:
1. The invited user should log in to their Atlassian account. 2. Navigate to their 'Account Settings,' select the 'Email' tab, and access the 'Email Preferences' center. 3. Ensure that the 'Product Invitations' option is enabled. 4. Workspace admins should cancel any existing invitations and send a fresh one after the preferences are updated.
By updating these settings, invitation emails should be successfully delivered. If necessary, re-send the invitation to trigger the email.
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