User cannot accept invitation to Bitbucket Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
You may encounter an issue where you or a user that you have invited to join a Bitbucket Cloud workspace is unable to accept the invitation when clicking on the Accept Invitation button found in the email.
Environment
Bitbucket Cloud
Diagnosis
Upon clicking the button to accept the invitation, the user is redirected to log in to their Atlassian account. However, after logging in, the user is redirected to this URL: https://start.atlassian.com/ instead of the correct URL necessary to accept the invitation.
Cause
If you or your organisation has implemented email cybersecurity measures, this can impact legitimate URL redirections if our Atlassian email addresses are not added to your security whitelist.
You can determine if this is the problem or not by hovering your mouse over the button to accept the invite. You may notice that the link to accept the invitation will have some form of application-specific text added to the beginning of the URL. For example: "
https://testdefender.example.com/safe-redirect/
https://id.atlassian.com
"
Solution
To resolve this, your email administrator will need to whitelist our Atlassian email addresses as follows to ensure that our emails are not blocked from being received or otherwise impacted by an issue such as this:
1 2 3 4 5
noreply@am.atlassian.com noreply+XXXXXXX@id.atlassian.net no-reply@atlassian.com noreply@mailer.atlassian.com notifications-noreply@bitbucket.org
Once this has been actioned, you/the user should be able to accept the invitation. You may need to have the invitation re-sent if the redirect is still occurring.
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