Unable to synchronize bitbucket repositories with Jira Server instance

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Upon integrating Jira Server with Bitbucket Cloud, repositories list doesn't appear in Jira server under DVCS accountsBitbucket workspace(workspace ID)

Diagnosis

In the Jira server logs, typically located at /var/atlassian/application-data/jira/log/atlassain-jira.log, you would see an error message as below,

1 Caesium-1-3 DEBUG ServiceRunner [c.a.j.p.dvcs.service.RepositorySyncServiceImpl] Repository sync already in progress, ignoring request

This means there was a stale/corrupt repository sync process in progress preventing any new repository sync request.

Solution

The issue could be to due to the last repository sync process not being terminated gracefully.

  1. Delete the Link between Jira and Bitbucket Workspace from Jira instance.

    • Navigate to "Application -> DVCS accounts", then "Delete" the Bitbucket Workspace with the issue.

  2. Once the Bitbucket Workspace is removed in Jira, relink your workspace with your OAuth key and secret

    • Do ensure that that your OAuth credential do have the right permission described in our document

  3. If the re-linking doesn't help, restart Jira service, this should remove/stop any stale ongoing sync process that was running previously.

  4. If required, re-connect Jira Server with Bitbucket Cloud after restart.

  5. If the issue still exists after following the above steps, please reach out to support team by attaching the support zip logs.

    1. Steps to generate Support zip:

      1. If the repositories still do not sync, do provide us with the following detail, as this will help us identify other workarounds:

        • Screenshot of your current "DVCS accounts" page

        • Support Zip: "System > Troubleshooting and support tools > Create Support Zip"

Updated on April 8, 2025

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