Unable to find the user in User Directory

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

A workspace admin may sometimes experience an issue in searching for a specific user from "workspace settings > user directory". It does not return the user. Admin might find the user from exported users list

Diagnosis

Verify if the user exists from the list manually:

  • Navigate to "User Directory"

  • Scroll through the pages manually to find the user from the list

Solution

Reason for this scenario was found to be, these users do not have Atlassian accounts. Make sure that the user creates Atlassian Account from their primary email address associated with Bitbucket Cloud account from https://id.atlassian.com. The issue should be resolved after having their Atlassian accounts linked to Bitbucket Cloud

If in case, you would like to remove the user from the workspace, you can follow the steps outlined in this document - How to remove Bitbucket Cloud users from the plan?

Updated on April 8, 2025

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