Unable to change project for a repository - "Please fix errors below: needs your attention" error
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
This KB article provides context for why error messages may occur when attempting to transfer a repository into a private or public project and how to resolve the issue.
Diagnosis
You are attempting to transfer a repository from one workspace to another. The repository is either public or private and is being transferred into a matching public or private project.
The following error message is encountered, however, and prevents the transfer from completing:
1
2
3
4
Please fix errors below:
needs your attention
needs your attention
needs your attention
Cause
The most common causes are as follows:
The receiving workspace/project is public whereas the repository being transferred is private - private repositories are unable to be transferred into public workspaces/projects
The receiving workspace/project is private whereas the repository being transferred is public - public repositories are unable to be transferred into private workspaces/projects
The repository that is being transferred has either a private issue tracker or a private wiki and cannot be transferred into a public project/workspace
The repository that is being transferred has either a public issue tracker or a public wiki and cannot be transferred into a private project/workspace
Solution
You will need to check the workspace, project and repository settings for the receiving workspace and make sure that these match the repository that is being transferred (public for a public repository and private for a private repository):
Workspace: Click ⚙ > Workspace Settings > General > Privacy
Project: Access Projects > Selected Project > Project Settings > Project Details > Privacy
Repository: Access Repository Settings > Repository Details > Access Level
If these match - the next step is to check that both the wiki and issue tracker (if there is one) on the transfer repository match the receiving workspace/project:
Issue Tracker: Navigate to Repository Settings > Issues: Issue Tracker and then change the setting to either a public or private issue tracker based on the receiving workspace/project
Wiki: Navigate to Repository Settings > Features: Wiki and then change the setting to either a public or private wiki based on the receiving workspace/project
Once you are sure that all settings above are matching between the transfer repository and the receiving workspace/project, attempt the transfer again - this should complete without issues
If you are still unable to transfer the repository, please raise a support ticket or raise a community support ticket for further assistance with this.
Was this helpful?