"Something went wrong" occurs when opening a Bitbucket page
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When trying to open a Bitbucket page, such as pull requests or commits, a page appears with the message "Something went wrong" and the desired content is not displayed.
Diagnosis
Try opening the same page where the issue is happening using another browser or an incognito tab.
Also, please check our documentation: Browser Troubleshooting Guide
Cause
First, what is the cache? The cache is a temporary storage area in memory or disk with recently downloaded Web pages. As you navigate from page to page on the Web, caching these pages in memory makes the process of returning to previous pages much faster without having to re-download them. However, this can also cause some issues, for example, old versions of cached files that are not updated with the latest versions of the site can cause issues with incompatible formatting, broken JavaScript, and incorrect images, which can generate the page "Something went wrong " on Bitbucket.
Solution
This issue can be resolved by clearing the browser cache. Below is the official documentation of some browsers on how to clear the cache:
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